Server-side Requirements

Operating Systems

Linux distributions (RedHat, Ubuntu, Debian, CentOS) are recommended for the production setup. Windows 7 and above and Mac OS X can be used for the development environment.

Software

HarmonyCMS applications are compatible with most web servers with PHP support, but we recommend the following configuration:

Web Server

Apache 2.2.x or 2.4.x

Nginx (latest mainline or stable version)

PHP

PHP 7.1.3 and above

PHP Extensions

  • openssl

  • intl

  • zip

Database

Such as Symfony, we don't provide a component to work with the database. However, our HarmonyFlex tool provide automatically the right Doctrine component needed to connect to the database server.

Off-course, you can install any Doctrine component to connect to your database server.

For now, only MySQL, PostgreSQL and SQLite are tested with HarmonyCMS.